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摘要 

    外觀呈紫紅色的甜菜紅素，富含於紅龍果肉內，以冷凍、過濾與離心的步驟取得。同時

由鎢絲燈泡、科學 maker 的分光器、手機與電腦軟體 Image J、Excel 2016 組成簡易光譜儀。

簡易光譜儀可測量甜菜紅素最大吸收峰波長 λmax=538nm 與繪出吸收光譜圖。吸收光譜圖的吸

光度 A 值，可得知甜菜紅素在紅龍果肉的含量。甜菜紅素在 pH 值 3~9 最穩定、在氫氧化鈉

溶液 pH 值>10 環境、乙醇為溶劑、芬頓試劑與硝酸鐵溶液時，會降解成黃色的甜菜醛胺酸

λmax=420~450nm 和無色的環多巴。甜菜紅素可與 Cu2+、Fe2+、Pb2+、Co2+、Ni2+、Zn2+螯合配

位成錯合物，外觀呈現紫色、紫紅色、粉紅色、橘紅色、黃色、橘色，λmax 會往短波長移動。

再加入 EDTA 後，又恢復成甜菜紅素。發現 Cu2+與甜菜紅素的螯合配位最好，可以偵測 Cu2+ 

至 1ppm。  

壹、研究動機

    紅龍果原產於南美洲，近年來引進台灣種植，而在台灣風土適應佳，病蟲害少且農藥用

量低，已經成為一年四季常見的水果，而其果肉色澤鮮紅多汁（圖一），相當吸引我們的注意。

翻閱文獻，紅龍果肉呈現紫紅色是因為富含甜菜紅素，可作為天然色素、及抗氧化的功能。

色澤鮮豔的甜菜紅素 Betalain（圖二）是一個 1,7-重氮七聚物結構的衍生物，由甜菜醛胺酸

betalamic acid 與環多巴 cyclo-Dopa 結合而成，其紫紅色歸因於共軛不飽和雙鍵的存在引起共

振結構，可見光之最大吸收峰波長 λmax 約在 535-538nm
［1］。二年級下學期自然與生活科技第

三章酸鹼鹽的課程裡［3］，說明葡萄、紅鳳菜與高麗菜這些植物皆含有花青素，可作為酸鹼指

示劑，和花青素類似，甜菜紅素在不同 pH 值環境表現不同顏色，也代表吸收不同可見光的波

長。我們想藉由製作簡易光譜儀，分析甜菜紅素的吸收光譜波長，了解其特性。 

圖一  紅龍果的外觀與果肉 圖二 甜菜紅素 Betalain 化學結構 
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貳、研究目的 

一、製作簡易光譜儀 

二、紅龍果肉色素之甜菜紅素取得 

三、以簡易光譜儀測量分析甜菜紅素稀釋不同濃度、不同有機溶劑、不同 pH 值、芬頓試劑、

不同的重金屬離子的吸收光譜 

參、研究設備及器材 

一、研究設備 

1.水果刀、2.紗布手帕、3.離心機、4.離心管 8 支、5.電子天平 1 台、6.刮勺 2 支、7.稱量紙 50

張、8.紙箱 1 個、9.黑色壁報紙 1 張、10.微量吸管（micropipette）1mL 1 支、200μ L1 支、11.

微量吸管吸頭 1mL 10 個、200μL 20 個、12.滴管 10 支、13.燒杯 50mL 5 個、100mL 5 個、14.

血清瓶 1 個、15.玻璃比色管 2 個、16.塑膠比色管 20 個、17.黑色膠帶 1 捆、18.剪刀 1 把、

19.科學 maker 分光器 1 個、20.手機 1 台、21.腳架 1 台、22.手機夾 1 個、23.雙面膠 1 卷、24.

省電燈泡、25.鎢絲燈泡 3W、26.檯燈燈座、27.樂高積木、28.燈泡座、29.插座延長線、30.影

像分析軟體 Image J、31.數據分析軟體 Microsoft Office Excel 2016 

二、研究藥品 

1.紅龍果 20 顆、2.硫酸銅 CuSO4∙5H2O 500g 1 瓶、3.氫氧化鈉 NaOH 500g 1 瓶、4.濃鹽酸 12M 

500mL 1 瓶、5.六水合硫酸銨亞鐵 Fe(NH4)2(SO4)2∙6H2O 500g 1 瓶、6.甲醇 500mL 1 瓶、7.藥用

酒精 500mL 1 瓶、8.丙酮 500mL 1 瓶、9.氯化亞鈷 CoCl2∙6H2O 500g 1 瓶、10.硝酸鉛 Pb(NO3)2 

500g 1 瓶、11.異丙醇 500mL 1 瓶、12.廣用試紙 1 盒、13.R.O 逆滲透水、14. H2O2 30% 500mL 

1 瓶、15.乙二胺四乙酸二鈉 EDTA 500g1 瓶、16.硝酸鎳 Ni(NO3)2∙6H2O 500g 1 瓶、17.氯化錳

MnCl2∙4H2O 500g 1 瓶、18.硝酸鐵 Fe(NO3)3∙9H2O 500g 1 瓶、19.硫酸鋅 ZnSO4∙7H2O 500g 1 瓶 

肆、研究過程或方法 

    研究過程可分成三個部分，分別是簡易光譜儀的製作、紅龍果肉之甜菜紅素的取得及利

用簡易光譜儀研究甜菜紅素的特性： 

一、簡易光譜儀的製作 

    光譜儀是最常用於物質結構鑑定分析的儀器，但是國中的實驗室，並沒有此項儀器，於

是參考多篇文獻並改良製作簡易光譜儀。光譜儀是由光源、樣品槽（樣品比色管）、分光器、

光譜接收器（手機光譜儀）所組成，當光源發射的入射光 Io 通過樣品容器時被容器中的物質

吸收部份的光，透射光 It經分光器分光後，到達光譜接收器再由電腦分析處理（Image J、Excel）

轉化成光譜圖，經分析比對光譜資料可以了解物質的結構和成分，圖三為光譜儀構造示意圖，

其製作步驟如下［6，7］。 

（一）暗箱的製作 
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1.使用光譜儀，必須隔絕外部所有光源否則會影響實驗結果，將光譜儀所有元件置入暗箱中。  

2.暗箱由一紙箱，內部則以黑色壁報紙貼滿。  

 

圖三 光譜儀構造示意圖 

（二）光源 

1.本實驗使用 3W 鎢絲燈泡作為光源，是連續光譜（波長約 380nm~680nm）。使用省電螺旋燈

泡作為校正光源，是不連續光譜，在波長 546nm 和波長 611nm 有激發光，作為光譜校準使

用。  

2.將燈座以樂高積木與黑色膠帶固定，裝上 3W 鎢絲燈泡，連接單一插座延長線，使用電源

110 伏特。 

（三）樣品槽 

樣品槽是以連接（二）光源繼續以樂高積木堆疊成空心長方體結構，可以讓放入方形比色管，

並在放比色管的一面，放上黑色紙板，紙板開一長 3 公分，寬 0.3 公分隙縫。 

  

圖四 暗箱與狹縫 圖五 光源樣品槽 
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（四）分光器與光譜接收器：使用科學 Maker 的分光器連接手機，為手機光譜儀，由於該裝

置具有分光器與光譜接收的功能，以手機的照相功能拍攝、記錄分光圖。將手機光譜儀的狹

縫貼近黑色紙板的隙縫，並以腳架固定，就為光譜儀。 

 

圖六 光譜儀 

（五）光譜資料轉換 

1.下載影像分析軟體 Image J 

2.將手機光譜儀所拍攝的分光圖照片，以 Image J 及 Excel 2016 處理，就可以得到吸收光譜圖 

（六）校準光譜儀 

1.開啟 Image J，工具列 File 處，選擇 Open，開啟省電燈泡之分光照片（圖七）。 

2.使用矩形工具，選取一長方形範圍，工具列 Edit → Selection →Specify，設定矩形位置及大

小（表一）。並再次選取工具列 Analyze → Plot Profile，如此就可以得到橫軸為位置像素，縱

軸為強度的圖八。 

 

 

 

 

 

 

 

3.在圖八中，找到最右端的波峰座標數字（573, 16.83），與右端的第二高峰座標數字（424, 19.57）。 

4.Image J 的工具列中，選 Analyze → Tools → Curve Fitting，清除欄位的數字，再輸入 573  

611，換行輸入 424  546，選 Fit ，得線性函數 y= 0.43624x +361.0356，因為省電燈泡紅光波

長 611nm，綠光波長 546nm，就可以將橫坐標的位置像素轉換成波長。 

表一 設定矩形位置及大小參數 

項目 數值 

Width 750 

Height 400 

X Coordinate 690 

Y Coordinate 495 
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圖七 省電燈泡之分光照片 圖八  

5.選擇圖上的功能 List→ Plot Values，得到（X 欄，Y 欄）數據→ Edit→Select All→ Copy。 

6.開啟 Excel 2016 →選擇空白活頁簿→貼上 5.中的數據，並在 C1 欄位輸入 y= 0.43624x 

+361.0356，A 欄的位置像素數據已轉換成波長在 C 欄，並將 B 欄的數據貼在 D 欄。 

7.選取 C、D 欄數據，在 Excel 工作列的插入→散佈圖，即可得已校準波長，橫坐標為波長，

縱座標為強度之省電燈泡光譜圖（圖十五）。日後所有樣品拍攝照片以矩形的選取範圍，就是

以省電燈泡分光圖為基準，就可以訂出光譜波長所在位置。 

（七）簡易光譜儀製作過程 

1.手機光譜儀先拍攝省電燈泡分光圖（圖九）。 

2.取 4mL 蒸餾水，放入方形比色管，置於樣品槽中，開啟光源與手機光譜儀，拍攝只有水的

分光圖（圖十）。 

3.另取一方形比色管，接著放入 2.5%甜菜紅素 4mL，置於樣品槽中，開啟光源與手機光譜儀，

拍攝分光圖（圖十一）。 

4.開啟 Image J，在 File 處，選擇 Open，依序開啟省電燈泡之色帶圖片、水的分光圖片及甜菜

紅素的分光圖片。 

   

          圖九                       圖十                       圖十一 

5.在 Image J 的工具列中，選 Stacks → Images to Stack，即可將三張圖疊在一起。 

6.接著使用矩形工具，選取一長方形範圍，工具列 Edit → Selection →Specify，設定矩形位置

及大小（表一）。 

7.在 Image J 的工具列中，選 Image→ Crop，去除旁邊黑色背景，為三張疊圖的分光圖。 

8.在鍵盤上同時按 Ctrl+A+K，如此就可以得到橫軸（X 欄）為位置像素，縱軸（Y 欄）為強
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度的省電燈泡光譜圖。 

9.在圖中，找到最右端的波峰座標數字（613, 24.32），與右端的第二高峰座標數字（450, 30.55）。 

10.Image J 的工具列中，選 Analyze → Tools → Curve Fitting，清除欄位的數字，再輸入 613  

611，換行輸入 450  546，選 Fit，得線性函數 y= 0.39877x +366.522，因為省電燈泡紅光波長

611nm，綠光波長 546nm，就可以將橫坐標的位置像素轉換成波長。 

11.選擇圖上的功能 List→ Plot Values，得到（X 欄，Y 欄）數據→ Edit→Select All→ Copy。 

12.開啟 Excel 2016 →選擇空白活頁簿→貼上 11.中的數據，並在 C1 欄位輸入 y= 0.39877x 

+366.522，而後整個 C 欄複製，A 欄的數據就可以轉換成波長在 C 欄。 

13.滑鼠點在 7.中水的分光圖，鍵盤上同時按 Ctrl+K，得水的光譜圖，選擇圖上的功能 List→ 

Plot Values，得到（X 欄，Y 欄）數據→ Edit→Select All→ Copy。 

14.貼上 13.中的數據於 D 欄與 E 欄，並去刪除 D 欄位所有數據，E 欄位就會左移成 D 欄位。 

15.滑鼠點在 7.中 2.5% 甜菜紅素的分光圖，鍵盤上同時按 Ctrl+K，得甜菜紅素的光譜圖，選

擇圖上的功能 List→ Plot Values，得到（X 欄，Y 欄）數據→ Edit→Select All→ Copy。 

16.貼上 15.中的數據於 E 欄與 F 欄，並去刪除 E 欄位，F 欄位就左移成 E 欄位。 

17.將 C 欄數據複製，並貼於 G 欄。 

18.在 H1 欄位輸入=log(D1/E1)，並整欄複製後，此 H 欄數據即為甜菜紅素的吸收度。 

19.選取 G 欄與 H 欄，在 Excel 工作列的插入→X、Y 散佈圖，得到甜菜紅素的吸收光譜圖。 

二、紅龍果肉色素之甜菜紅素的製備 

1.市場購買紅龍果，取 3 顆以水果刀剝去外皮，將果肉切成數塊，放入保鮮盒，放入冰箱冷凍

48 小時，拿出退冰，回到室溫。 

2.回到室溫後，紅龍果肉的細胞壁破裂，紫紅色果汁就會大量滲出。 

3.以紗布方巾當作濾網（圖十二），過濾 2.中的紫紅色果汁，濾出果肉、種子與黏稠果漿約可

得 300mL。 

4.再將 3.中的濾液，分別放入離心管中，共放入 8 管於離心機（圖十三），以轉速 6000rpm，

離心 15 分鐘後，待離心機停止，以滴管取離心管中紫紅色液體上層液 6mL，放入血清瓶中

（圖十四），我們稱之為原汁，於日後的實驗，這樣步驟所得的紫紅色液體，我們就稱為 100% 

甜菜紅素。加水稀釋成原來的 1/20 時，其濃度就稱為 5%。  

   

          圖十二                     圖十三                      圖十四 
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三、簡易光譜儀對甜菜紅素性質之研究 

 

測量甜菜紅素在各種環境的吸收光譜圖步驟： 

1.開啟省電燈泡光源，手機光譜儀先拍攝省電燈泡分光圖。 

2.取 4mL 蒸餾水，放入方形比色管，置於樣品槽中，開啟光源與手機光譜儀，拍攝只有水的

分光圖。 

3.以微量滴管取 5%甜菜紅素溶液 10mL 於燒杯中，再加入 10mL 蒸餾水，則得 2.5%甜菜紅素

溶液，取 4mL 放入方形比色管，置於樣品槽中，拍攝分光圖。 

紅龍果肉色素之甜菜紅素的製備 

（一）稀釋不同濃度甜菜紅素 

（二）甜菜紅素在不同有機溶劑 

（三）甜菜紅素在 HCl 溶液中不同 pH 值 

（四）甜菜紅素在 NaOH 溶液中不同 pH 值 

（五）以芬頓試劑 Fe2+-H2O2探討甜菜紅素之抗氧化能力 

 

（六）甜菜紅素加入不同重金屬鹽類 CuSO4、FeSO4、Pb(NO3)2、

CoCl2、Ni(NO3)2、Fe(NO3)3、MnCl2、ZnSO4 

以簡易光譜儀測量甜菜紅素的吸收光譜 

（七）加入 EDTA 證明重金屬離子-甜菜紅素螯合 

（八）比較甜菜紅素對不同重金屬離子螯合能力 

（九）甜菜紅素對銅離子 Cu2+的偵測極限 
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4.以微量滴管取 5%甜菜紅素溶液 10mL 於燒杯中，再加入不同試劑 10mL，成混合液 20mL。

取 4mL 放入方形比色管，置於樣品槽中，拍攝分光圖。 

5.將 1.~4.分光圖，按照（七）簡易光譜儀操作步驟，即可得甜菜紅素在不同環境的吸收光譜

圖。 

伍、研究結果與討論 

一、簡易光譜儀的製作 

    我們參考文獻與使用科學 maker 分光器接上手機，製作簡易的光譜儀，手機拍攝省電燈

泡的分光照片（圖七），因為省電燈泡光源是線光譜，只發出數條特定波長的光，才能訂出波

長的位置，以影像分析軟體 Image J 處理，可把分光照的影像轉換成，橫軸為位置像素，縱軸

為光強度像素圖（圖八）。同時圖中（圖八）位置像素有對應數值，光強度像素也有對應的數

值。 

 

圖十五 省電燈泡光譜圖 

位置像素數值以 Excel 2016，在欄位上演算線性函數，就可將位置像素數值轉換成橫坐標的

對應波長λ，光強度像素圖數值放在縱座標為省電燈泡光的強度，圖十五即為省電燈泡光譜

圖。在圖十五中由右至左，幾條特定省電燈泡線光譜波長λ，分別為紅光 611nm、綠光 546nm

及藍光 436nm。使用科學 maker 分光器，拍攝的分光圖與轉換成光譜圖，雜訊很低，而且分

光器與手機連接是固定不動，日後所有樣品拍攝分光圖，與省電燈泡分光圖（圖九）一起疊

圖，以省電燈泡分光圖為基準，就可以訂出樣品光譜波長所在位置，不會跑掉或有誤差，此

一步驟，這就是校準光譜儀。 

    簡易光譜儀，以鎢絲燈為光源，此光源是連續光譜（波長約 380nm~680nm），才可以得知

樣品在可見光範圍 400nm-700nm，哪個波長光被樣品吸收。拍攝純水的分光圖與 2.5%甜菜紅

素水溶液的分光圖，以 Image J 軟體，可分別得到純水像素強度，就為 Io（Io為入射光）與 2.5%
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甜菜紅素水溶液像素強度，就為 It（It 為透射光），將兩者的數據，以 Excel 2016 軟體，在欄

位上輸入運算公式，即 log10 

I0

It
，所得的值，就是吸光度 A，這樣的設計步驟，在 Excel 2016

數據繪出的圖，就是甜菜紅素的吸收光譜圖（圖十六）。圖十六中最大吸收峰波長 λmax=538nm，

與文獻報導符合［1，4］。 

 

圖十六 2.5%甜菜紅素吸收光譜圖 

    除此之外，依比爾—朗博定律（Beer–Lambert law）：一束單色光照射於一吸收介質表面，

在通過一定厚度的介質後，由於介質吸收了一部分光能，透射光的強度就要減弱。吸收介質

的濃度愈大，介質的厚度愈大，則光強度的減弱愈顯著，其關係為： 

A = log10 

I0

It
 = log10 

1

T
 = ε•b•c             （式一） 

其中： 

A：吸光度、 Io： 入射光的強度、  T：透射比、 It：透射光的強度、 

ε：莫耳吸光係數、 b：吸收介質的厚度，以 cm 為單位、 c：吸光物質的濃度 mol/L 

，所以在圖十六縱軸的吸光度 A 值=0.89，文獻報導甜菜紅素的 ε=60000L/mol
［5］，樣品槽比

色管的厚度 b=1cm，代入（式一）可得甜菜紅素的濃度。［甜菜紅素］=1.4810-5M。由儀器

的設計到數據轉換成光譜，自製的簡易光譜儀確實可準確測量物質的吸收光譜。 

二、紅龍果肉色素之甜菜紅素取得 

    甜菜紅素是一種水溶性的天然色素，大量存在於紅龍果的果皮與果肉中，此次實驗，我
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們是以冷凍法來取得。先將紅龍果皮去除，其果肉分切成小塊，放入冷凍庫 48 小時，再回溫

到室溫，果肉的細胞壁在-18℃，被冰的體積膨脹撐大，回到室溫水的體積縮小，細胞壁就會

破裂，色素原在細胞裡，就溶於果汁裡。這種方式比用榨汁機榨汁，效果比較好。之前用榨

汁機，果肉幾乎都留在榨汁機的濾網裡，流出的果汁量少，還混有果膠質。以冷凍法，只要

將紫紅色果汁以紗布手帕過濾，儘量擰乾，果肉、果肉籽與果膠質也會留在紗布上，最後再

以離心機離心，在高速運轉下，離心管還是呈現幾乎無法透光紫紅色液體，只有少部白色果

膠質會沉澱在離心管的下端，以滴管吸取上層液體，我們就以該液體的濃度為 100%，再加水

稀釋成 2.5%（DF=40），以簡易光譜儀測量得吸收光譜圖，光譜圖的吸光度 A 值=0.89，代入

式二中 

甜菜紅素的含量［5］（mg/L）= 
   A× DF× MW× 1000   

𝜀×L
    （式二） 

A：吸光度，DF：稀釋倍數，MW= 甜菜紅素分子量= 550 g/mol， 

           ε= 60000 L/mol cm in H2O，L = 比色管寬度 = 1 cm 

即甜菜紅素含量 326 mg/L。而文獻中［2］，以加熱與溶劑從紅龍果肉萃取甜菜紅素，純度雖然

較高，但過程中甜菜紅素會發生降解，降低產率，所以甜菜紅素含量 120±25 mg/L。 

三、以簡易光譜儀分析甜菜紅素稀釋不同濃度、不同 pH 值、芬頓試劑、不同的重金屬離子的

吸收光譜 

1.甜菜紅素稀釋成不同濃度的吸收光譜圖 

 

圖十七 不同濃度甜菜紅素的吸收光譜圖 

    由於甜菜紅素的吸光值很高，ε = 60000 L/mol，離心後的甜菜紅素溶液顏色很深，幾乎無
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法透光，就設定離心後的甜菜紅素的濃度為 100%，逐漸加入去離子水，依文獻的方法稀釋成

5%時，才能繪出光譜圖，得 λmax= 526nm，文獻報導 A 值的範圍，0.8≤A≤1.0，當繼續稀釋成

2.5%時，才有 λmax= 538nm 出現，當甜菜紅素濃度高時，可能分子與分子間作用力，最大吸收

峰波長 λmax會往短波長移動，故所有的光譜實驗，都須將紅龍果汁稀釋至 2.5%以下。 

    將稀釋濃度與吸光度作檢量線（圖十八），得 y=0.1091x-310-16 線性函數，直線上的

R2=0.997，表示為可信度高，未來只要有吸光度 A，就可以得知甜菜紅素濃度。 

 

圖十八 甜菜紅素的檢量線 

2.甜菜紅素在不同溶劑中的吸收光譜圖 

 

圖十九 甜菜紅素在不同溶劑的吸收光譜圖 
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    將甜菜紅素放入水：溶劑=1：1，外觀呈色皆為紫紅色溶液，圖十九吸收光譜圖差異就非

常明顯，甲醇、乙醇、異丙醇與丙酮在 538nm 的吸光度降低，波形也相似，說明甜菜紅素若

在這四種有機溶劑中不安定會分解。尤其在乙醇溶液中，在 410nm、460nm~480nm 與 538nm

皆有吸收峰，538nm 的吸光度降低，部分甜菜紅素已經降解成其他物質，460nm~480nm 則為

一起存在於紅龍果肉的物質，為甜菜黃素 betaxanthin（圖二十甜菜黃素結構），含量通常約為

甜菜紅素的 1/10，當甜菜紅素含量少時，波長吸收峰部分就可以看到。甜菜紅素在醇類不穩

定，由圖十九吸收光譜圖中，乙醇最為明顯，文獻報導，常以乙醇萃取紅龍果中的甜菜紅素，

與我們的方法相比，含量較低，可能與此因素有關。 

 

圖二十 甜菜黃素 betaxanthin 結構，λmax=460~480nm 

3.甜菜紅素在 HCl 溶液中不同 pH 值下的吸收光譜 

    甜菜紅素放入配製不同濃度的 HCl 溶液，以廣用試紙測其 pH 值，溶液皆為呈酸性，並

且外觀亦呈紫紅色如圖二十一。在圖二十三吸收光譜圖中，不同的 pH 值，波形與皆甜菜紅素

相似，隨 pH 值降低，在 538nm 吸光度也降低，波峰有 2-3nm 左移，太酸環境會使甜菜紅素

發生異構化或去糖苷但不會裂解。文獻報導是以 λmax=538nm 的吸光度來代表甜菜紅素的穩定

度。吸光度越高者，穩定度越高，甜菜紅素 pH=5.8 > pH=6 > pH=7 > pH=3 > pH=2 >pH=1。 

     

圖二十一 甜菜紅素在不同濃度 HCl 的呈色    圖二十二甜菜紅素在不同濃度 NaOH 的呈色 
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圖二十三 甜菜紅素在 HCl 溶液中不同 pH 值的吸收光譜 

4.甜菜紅素在 NaOH 溶液中不同 pH 值下的吸收光譜 

 

圖二十四 甜菜紅素在 NaOH 溶液中不同 pH 值的吸收光譜 

    甜菜紅素放入配製不同濃度的 NaOH 溶液，以廣用試紙測其 pH 值=8~13，溶液皆為呈鹼
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性，外觀顏色隨著 pH 值增加，依序為粉紅、紫色、黃色、淡黃色、淺綠色如圖二十二，差異

相當大，圖二十四吸收光譜圖的變化更為明顯，甜菜紅素、pH=8 與 pH=9，吸收光譜的波形

相似，隨著 pH 值增加，在 538nm 的吸光度降低。當 pH>10 時，在 430nm 處有吸收峰，為甜

菜醛胺酸 betalamic acid，更鹼的環境時，吸光度增加，在 538nm 吸收峰消失，甜菜紅素已經

降解，外觀也沒有紫紅色。這是甜菜紅素於 C-11 被 OH-親核性攻擊（式三），亞胺腱斷裂，

降解成甜菜醛胺酸 betalamic acid（黃色的，λmax=420~450nm）與 cyclo-dopa 環多巴（無色的），

造成共振不連續而失去顏色。說明甜菜紅素於 pH>10 的鹼性環境中不穩定，色素分子會分解，

紫紅色消失。 

    由 3.與 4.的實驗結果，可以 λmax=538nm 的吸光度來判定甜菜紅素在酸鹼環境中的穩定

度，pH 值 3~9 較為穩定，與文獻［1］符合。 

 

（式三） 

5.甜菜紅素加入芬頓試劑 Fe2+-H2O2 的吸收光譜圖 

    過氧化氫 H2O2 溶液中，加入少量亞鐵離子 Fe2+，即產生大量的氫氧自由基 HO∙，是一種

強氧化劑，通常可以將有機物分解，此為芬頓試劑，一加入紫紅色甜菜紅素溶液，紫紅色立

即褪色為黃褐色，如圖二十五所示。加入更多的 H2O2 時，溶液呈黃色，還有氣體產生，此種

氣體為氧氣。 

 

圖二十五 甜菜紅素加入芬頓試劑 
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圖二十六 甜菜紅素加入芬頓試劑的吸收光譜圖 

    圖二十六吸收光譜圖中，甜菜紅素溶液只加入過氧化氫 H2O2 或亞鐵離子 Fe2+時，皆有最

大吸收峰 λmax=538nm，表示此兩物質，不影響甜菜紅素的結構。加入芬頓試劑時，外觀紫紅

色立即消失，而在圖二十六的吸收光譜圖 λmax=538nm 也不見，但在 420nm 處有很大的吸收，

為甜菜醛胺酸 betalamic acid ，甜菜紅素結構被芬頓試劑的氫氧自由基所分解，為氧化還原反

應，故甜菜紅素為是一抗氧化劑（還原劑），具抗氧化功能。利用芬頓試劑產生的自由基當作

是人們身體內的自由基，攝取紅龍果，紅龍果內的甜菜紅素就是作為清除體內的自由基的抗

氧化劑，是不錯的保健食品。 

6.甜菜紅素加入不同的重金屬離子 Cu2+、Fe2+、Pb2+、Co2+、Ni2+、Fe3+、Mn2+、Zn2+的吸收光

譜 

 

圖二十七 甜菜紅素加入 Cu2+、Fe2+、Pb2+、Co2+、Ni2+、Fe3+、Mn2+、Zn2+外觀呈色 

    在紫紅色甜菜紅素水溶液中，分別加入含有 Cu2+、Fe2+、Pb2+、Co2+、Ni2+、Fe3+、Mn2+、
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Zn2+離子的重金屬鹽類，外觀呈色會改變如圖二十七。加入淡藍色的硫酸銅，為 Cu2+-甜菜紅

素溶液，顏色呈紫色；加入淺黃色的硫酸亞鐵，為 Fe2+-甜菜紅素溶液，顏色呈紫紅色；加入

無色的硫酸鉛，為 Pb2+-甜菜紅素溶液，顏色呈淡粉紅色；加入紅色的氯化亞鈷，為 Co2+-甜菜

紅素溶液，顏色呈橘紅色；加入綠色的硝酸鎳，為 Ni2+-甜菜紅素溶液，顏色呈黃色；加入黃

色的硝酸鐵，為 Fe3+-甜菜紅素溶液，顏色呈黃色；加入無色的氯化錳，為 Mn2+-甜菜紅素溶

液，顏色呈紫紅色；加入無色的硫酸鋅，為 Zn2+-甜菜紅素溶液，顏色呈橘色。 

 

圖二十八 甜菜紅素加入硫酸銅的吸收光譜圖 

由圖二十八吸收光譜圖，只有藍色硫酸銅水溶液 λmax=660nm；紫紅色甜菜紅素水溶液

λmax=538nm；顏色呈紫色的 Cu2+-甜菜紅素溶液 λmax=500nm，兩種甜菜紅素溶液的最大吸收

峰波長差 Δλmax=38nm，吸收峰波長往短波長移動為藍位移，加入更多的硫酸銅時，在

500nm 的吸光度會下降，表示 Cu2+-甜菜紅素溶液不穩定。 

    在圖二十九的吸收光譜圖，只有淡黃色色硫酸亞鐵水溶液 λmax=407nm、λmax=690nm；只

有紫紅色甜菜紅素水溶液 λmax= 538nm；顏色呈紫紅色 Fe2+-甜菜紅素溶液 λmax= 540nm，兩種

甜菜紅素溶液的最大吸收峰波長差 Δλmax=2nm，吸收峰波長往短波長移動為紅位移，加入更

多的硫酸亞鐵，在 λmax=540nm 吸光度稍微下降。 
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圖二十九 甜菜紅素加入硫酸亞鐵的吸收光譜圖 

 

圖三十 甜菜紅素加入硝酸鉛的吸收光譜圖 
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圖三十一 甜菜紅素加入氯化亞鈷的吸收光譜圖 

 
圖三十二 甜菜紅素加入硝酸鎳的吸收光譜圖 
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圖三十三 甜菜紅素加入硝酸鐵的吸收光譜圖 

 

圖三十四 甜菜紅素加入氯化錳的吸收光譜圖 
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圖三十五 甜菜紅素加入硫酸鋅的吸收光譜圖 

    在圖三十的吸收光譜圖，紫紅色甜菜紅素水溶液 λmax=538nm；顏色呈淡粉紅色的 Pb2+-甜

菜紅素溶液最大吸收峰波長 λmax=495nm，兩種甜菜紅素溶液的最大吸收峰波長差 Δλmax= 43nm，

吸收峰波長往短波長移動為藍位移，加入更多的硝酸鉛，在 λmax=495nm 吸光度上升。 

    在圖三十一的吸收光譜圖，紅色氯化亞鈷水溶液 λmax=507nm；紫紅色甜菜紅素水溶液

λmax=538nm； 顏色呈橘紅色的 Co2+-甜菜紅素溶液 λmax=480nm，兩種甜菜紅素溶液的最大吸

收峰波長差 Δλmax=58nm，吸收峰波長往短波長移動為藍位移，在 λmax=480nm 吸光度上升。 

由圖三十二的吸收光譜圖，只有綠色硝酸鎳水溶液 λmax=614nm、λmax=418nm；紫紅色

甜菜紅素水溶液 λmax=538nm；顏色呈黃色的 Ni2+-甜菜紅素溶液 λmax=485nm，兩種甜菜紅素

溶液的最大吸收峰波長差 Δλmax=53nm，吸收峰波長往短波長移動為藍位移，加入更多的硝

酸鎳時，在 4850nm 的吸光度會下降，可能 Ni2+-甜菜紅素溶液不穩定。 

    在圖三十三的吸收光譜圖，只有黃色色硫酸亞鐵水溶液 λmax=436nm、λmax=464nm；紫紅

色甜菜紅素水溶液 λmax= 538nm；沒有 Fe3+-甜菜紅素溶液 λmax出現，在 420nm 處，有最大吸

收峰，此為甜菜紅素降解後的產物甜菜醛胺酸，說明甜菜紅素在硝酸鐵中不穩定，會發生降

解。  

    在圖三十四的吸收光譜圖，紫紅色甜菜紅素水溶液 λmax=538nm；加入 Mn2+離子後，顏色

呈紫紅色，λmax仍為 538nm，由於外觀呈色與最大吸收峰波長沒有改變，無法得知 Mn2+是否

與甜菜紅素螯合配位。 
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    在圖三十五的吸收光譜圖，紫紅色甜菜紅素水溶液 λmax=538nm；顏色呈橘色的 Zn2+-甜菜

紅素溶液 λmax=505nm，兩種甜菜紅素溶液的最大吸收峰波長差 Δλmax= 33nm，吸收峰波長往

短波長移動為藍位移，加入更多的硫酸鋅，在 λmax=505nm 吸光度下降。 

 

圖三十六 M2+-甜菜紅素錯合物結構示意圖 

    除了加入亞鐵離子外，甜菜紅素加入重金屬離子 Cu2+、Pb2+、Co2+、Ni2+、Zn2+，最大吸

收峰波長接往短波長移動，這是因為在甜菜紅素分子結構裡，有胺基與羧基，可提供電子對

與金屬離子配位，這種具有配位金屬離子的特質，稱之為螯合，就像螃蟹的螯夾住金屬離子，形

成 M2+-甜菜紅素錯合物（如圖三十六），使得原先甜菜紅素上共軛不飽和雙鍵的共振結構電子

密度改變，共振穩定度也會改變，最大吸收峰波長就會移動，往短波長移動，稱為藍位移。 

7. M2+-甜菜紅素錯合物加入 EDTA 的光譜圖    

    EDTA 是一種有機化合物，可以配位錳（II）、銅（II）、鐵（III）及鈷（II）等金屬離子組成

錯合物，它有 4 個羧基和 2 個胺基的構成六牙基的配位基，配位能力比甜菜紅素強，如圖三十

七。 

 

圖三十七 M2+-EDTA 錯合物結構示意圖 

    為證明重金屬離子 Cu2+、Fe2+、Pb2+、Co2+、Ni2+、Fe3+、Mn2+、Zn2+確實與甜菜紅素進行
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https://zh.wikipedia.org/wiki/%E9%8C%B3
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配位成錯合物。在甜菜紅素中加入過量的重金屬離子，形成 M2+-甜菜紅素錯合物，接著逐滴

加入 EDTA，錯合物上的 M2+就與 EDTA 形成 M2+-EDTA 錯合物，重金屬離子不再與甜菜紅

素配位，就恢復成甜菜紅素，圖三十八外觀呈色有部分恢復呈紫紅色，但因溶液中尚有 M2+-

EDTA 存在，外觀呈色是甜菜紅素與 M2+-EDTA 錯合物兩種溶液混合顏色。 

 

圖三十八 M2+-甜菜紅素錯合物加入 EDTA 外觀呈色 

    以簡易光譜儀測量甜菜紅素與 M2+-EDTA 錯合物兩種溶液，在吸收光譜圖三十九、四十、

四十一、四十二、四十三、四十六中最大吸收峰波長 538nm 有出現，恢復成甜菜紅素。 

 

圖三十九 Cu2+-甜菜紅素加入 EDTA 的吸收光譜圖 
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圖四十 Fe2+-甜菜紅素加入 EDTA 的吸收光譜圖 

 
圖四十一 Pb2+-甜菜紅素加入 EDTA 的吸收光譜圖 
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圖四十二 Co2+-甜菜紅素加入 EDTA 的吸收光譜圖 

 

圖四十三 Ni2+-甜菜紅素加入 EDTA 的吸收光譜圖 
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圖四十四 Fe3+-甜菜紅素加入 EDTA 的吸收光譜圖 

 

圖四十五 Mn2+-甜菜紅素加入 EDTA 的吸收光譜圖 
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圖四十六 Zn2+-甜菜紅素加入 EDTA 的吸收光譜圖 

    圖三十九吸收光譜圖中，Cu2+-甜菜紅素錯合物溶液 λmax=500nm，在逐漸加入的 EDTA 時，

最大吸收峰波長往 538nm 移動，此為甜菜紅素的最大吸收峰波長，表示甜菜紅素已無與 Cu2+

螯合，右端另一吸收峰 λmax=660nm，是為 Cu2+-EDTA 錯合物，其外觀呈色是深藍色，與紫紅

色甜菜紅素同時在比色管中，才使溶液呈現紫色。 

    圖四十吸收光譜圖中，Fe2+-甜菜紅素錯合物溶液 λmax=540nm，在逐漸加入的 EDTA 時，

最大吸收峰波長往 538nm 移動，此為甜菜紅素的最大吸收峰波長，最大吸收峰波長差異很小，

溶液外觀呈色皆為紫紅色，不易分辨顏色差別。 

圖四十一吸收光譜圖中，Pb2+-甜菜紅素錯合物溶液 λmax=495nm，在逐漸加入的 EDTA 時，

最大吸收峰波長往 538nm 移動，此為甜菜紅素的最大吸收峰波長，此時溶液會轉變回紫紅色，

表示甜菜紅素已無與 Pb2+螯合。 

圖四十二吸收光譜圖中，Co2+-甜菜紅素錯合物溶液 λmax=480nm，在逐漸加入的 EDTA 時，

最大吸收峰波長移到在 500~550nm，此時溶液外觀為紅紫色，這是因為溶液中有 Cu2+-EDTA

錯合物其最大吸收峰波長 λmax=504nm，其外觀呈色是紅色，與紫紅色甜菜紅素同時在比色管

中，才使溶液呈現紅紫色。 

圖四十三吸收光譜圖中，Ni2+-甜菜紅素錯合物溶液 λmax=485nm，在逐漸加入的 EDTA 時，
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最大吸收峰波長往 538nm 移動，此為甜菜紅素的最大吸收峰波長，此時溶液會轉變回紫紅色，

表示甜菜紅素已無與 Ni2+螯合。 

圖四十四吸收光譜圖中，Fe3+與甜菜紅素錯合物混合溶液，在逐漸加入的 EDTA 時，最大

吸收峰波長並沒有改變，也沒有甜菜紅素的最大吸收峰波長出現，表示溶液中已無甜菜紅素，

甜菜紅素在 Fe3+溶液中不穩定，已經降解成其他物質。 

圖四十五吸收光譜圖中，在 Mn2+與甜菜紅素混合溶液中，其 λmax=538nm 應是甜菜紅素，

在逐漸加入的 EDTA 時，λmax=538nm 並無移動，仍為甜菜紅素的最大吸收峰波長，此時溶液

仍是紫紅色，由此可說明 Mn2+並沒有與甜菜紅素進行螯合配位。 

圖四十六吸收光譜圖中，Zn2+-甜菜紅素錯合物溶液 λmax=505nm，在逐漸加入的 EDTA 時，

最大吸收峰波長往 538nm 移動，此為甜菜紅素的最大吸收峰波長，此時溶液會轉變回紫紅色，

表示甜菜紅素已無與 Zn2+螯合。 

表二 

加入 Mn+ M2+-甜 λmax 外觀呈色 Δλmax=538-λmax M2+-甜加入 EDTA 後

λmax 是否有恢復 538nm 

M2+是否有與甜菜紅素

螯合配位 

Cu2+ 500nm 紫色 38nm 是 是 

Fe2+ 540nm 紫紅色 -2nm 是 是 

Pb2+ 495nm 粉紅色 43nm 是 是 

Co2+ 480nm 橘紅色 58nm 是 是 

Ni2+ 485nm 紅色 53nm 是 是 

Fe3+ X 黃色 X 否 否 

Mn2+ 538nm 紫紅色 0 nm 是 否 

Zn2+ 505 橘色 33nm 是 是 

    將吸收光譜圖二十八~四十六整理成表二，說明甜菜紅素可與 Cu2+、Pb2+、Co2+、Ni2+、

Zn2+螯合配位，外觀呈色也會改變，在吸收光譜圖的 λmax 也往短波長移動，未來是可作為重

金屬離子指示劑。 

7. 比較甜菜紅素與不同重金屬離子 Cu2+、Pb2+、Co2+、Ni2+、Zn2+配位能力 

    我們發現，甜菜紅素確實可與 Cu2+、Pb2+、Co2+、Ni2+、Zn2+螯合配位，因此將這五種離

子，同時加入甜菜紅素溶液中，在圖四十七吸收光譜圖中，波長在 500nm、538nm 處，皆有

最大吸收峰 λmax的出現，與圖二十八至三十五比較，為 Cu2+-甜菜紅素與甜菜紅素的最大吸收

峰 λmax，表示 Cu2+較 Pb2+、Co2+、Ni2+、Zn2+更容易與甜菜紅素進行螯合配位，這個結果，也

符合 Irving-Williams effect
［8］。（歐文-威廉姆斯效應為由二價第一行過渡金屬離子形成的錯

合物同一週期增加至銅的最大穩定性：Mn2+<Fe2+<Co2+<Ni2+<Cu2+> Zn2+） 

 

https://en.wikipedia.org/wiki/Divalent
https://en.wikipedia.org/wiki/Transition_metal
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圖四十七 甜菜紅素加入 Cu2+、Pb2+、Co2+、Ni2+、Zn2+後的吸收光譜圖 

8. 甜菜紅素對銅離子 Cu2+的偵測極限 

取 2.5%甜菜紅素，以簡易光譜儀測其吸收光譜，共測 10 次。將 10 次的吸收光譜圖 538nm

處，紀錄吸光度的值如表三，以 Excel2016 計算其標準差 

表三 

次別 1 2 3 4 5 6 7 8 9 10 

吸光度 0.431 0.426 0.424 0.421 0.416 0.424 0.413 0.413 0.418 0.42 

 

標準差= 0.0054635 

 

    由 7.的實驗結果，選擇 Cu2+作偵測極限。於 2.5%，100mL 甜菜紅素溶液中，以微量吸

管加入硫酸銅溶液，以簡易光譜儀測量吸收光譜，並在光譜圖中波長 538nm 處，對應出吸

光度 A 值，作銅離子濃度與吸光度的檢量線（如圖四十八）。 
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圖四十八 硫酸銅濃度與 λmax=538nm 吸光度的檢量線 

Cu2+偵測極度濃度=3  
標準差

檢量線斜率
    （式四） 

將標準差=0.0054635，檢量線斜率=1074 代入式四中，可得 Cu2+偵測極度濃度=1.5210-5M，相

當於 0.92ppm，約為 1ppm。實驗結果說明甜菜紅素對 Cu2+的偵測，可達 1ppm。 

陸、結論 

1.以鎢絲燈泡、樂高積木、紙箱、科學 maker 分光器與手機，製作簡易光譜儀，再以手機拍攝

的分光照片。分光照片，利用影像分析軟體 Imag J，將影像轉換成位置像素數值與光強度數

值，數值再以 Excel 2016 運算，所畫的曲線圖，為橫坐標為波長，縱座標為光強度之光譜圖。 

2.吸收光譜圖則是利用比爾—朗博定律，A=log10

Io

 It 
 =εb c，I0 為純水光強度數值，It 為樣品

光強度數值，在 Excel 2016 運算，Io 與 It 在相同對應光波長，數值相除，以 Io 為底取對數

log，所得的數值，就為樣品的吸光度 A。以波長為橫坐標，吸光度 A 為縱坐標，畫出的曲線，

就為樣品的吸收光譜圖。甜菜紅素為樣品，以簡易光譜儀測量，畫出的吸收光譜圖，其最大

吸收峰波長 λmax=538nm，與文獻一致。另外也由吸收光譜圖中吸光度 A，A=εbc，又已知甜

菜紅素=60000 L/mol，b=1cm（比色管的長度），就可得知甜菜紅素的濃度，表示簡易光譜確

實可以準確測量本次研究甜菜紅素的吸收光譜。 

4.甜菜紅素大量存在於紅龍果的果肉，外觀呈紫紅色。取得方式將紅龍果果肉冷凍，回到室溫，

紗布過濾，濾液再以離心機離心，取上層液，紅龍果肉甜菜紅素含量 326 mg/L，為文獻報告

的 2 倍。 

5.甜菜紅素的消光係數數值很大，測量吸收光譜時，須取得的甜菜紅素溶液，稀釋至 2.5%以

下，才能使吸光度 A 值的範圍在 0.8≤A≤1.0，最大吸收峰波長 λmax=538nm，當甜菜紅素濃度

高時，最大吸收峰波長會往短波長移動。 

6.甜菜紅素濃度與吸光度的校正曲線之線性函數 A=0.1091×甜菜紅素濃度（mg/L）-310-16未

來只要有吸光度，就可以得知甜菜紅素濃度。 

y = -1074.3x + 1.0162
R² = 0.9813
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7.甜菜紅素在不同酸鹼環境中的穩定度，以最大吸收峰波長 λmax=538nm 吸光度 A 值大小作為

判斷，吸光度越高者，穩定度越高，甜菜紅素在 pH 值 3~9 最穩定、在 pH 值>10 環境不穩定，

色素分子會分解，紫紅色消失。 

8.甜菜紅素在醇類不穩定尤其是在乙醇溶液，故不宜以酒精為溶劑從紅龍果肉萃取甜菜紅素。 

9.當甜菜紅素與加入芬頓試劑時，紫紅色立刻褪去，表示具有抗氧化能力，可作為抗氧化劑。 

10.甜菜紅素可以與重金屬離子 Cu2+、Fe2+、Pb2+、Co2+、Ni2+、Zn2+螯合配位成錯合物 M2+-甜

菜紅素，造成甜菜紅素上共軛不飽和雙鍵的共振結構電子密度改變，共振穩定度也會改變，

造成外觀呈色改變，在吸收光譜圖中的 λmax 會往短波長移動。M2+-甜菜紅素錯合物溶液加入

EDTA 時，λmax會移回 538nm，為甜菜紅素最大吸收峰波長，外觀呈色恢復呈紫紅色。這樣的

結果，說明未來甜菜紅素可作為重金屬離子的指示劑。 

11.甜菜紅素與銅離子 Cu2+的螯合配位最好。 

12.以簡易光譜儀利用甜菜紅素與 Cu2+的配位螯合最好的性質，對 Cu2+濃度作偵測極限，可測

到 1ppm。 
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除了自製的光譜儀外，學生對分子的光吸收也有所了解，也從

分子結構了解為何與不同金屬離子形成錯合物會造成吸收峰的變

化。 
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摘要 

    外觀呈紫紅色的甜菜紅素，富含於紅龍果肉內，以冷凍、過濾

與離心的步驟取得。同時由鎢絲燈泡、科學 maker 的分光器、手機

與電腦軟體，組成簡易光譜儀。簡易光譜儀可測量甜菜紅素最大吸

收峰波長λmax=538nm 與畫出吸收光譜圖，結果與文獻的報導一致。

吸收光譜圖的吸光度 A 值，可得知甜菜紅素在紅龍果肉的含量。

甜菜紅素在 pH 值 5~9 最穩定、在氫氧化鈉溶液 pH 值>10 環境、

乙醇為溶劑與芬頓試劑時，會降解成黃色的甜菜醛胺酸 λmax=420-

450nm 和無色的環多巴。甜菜紅素可與 Cu2+、Fe2+、Pb2+、Co2+螯合

成錯合物，外觀呈現紫色、紫紅色、粉紅色、橘紅色，最大吸收峰

波長 λmax會往短波長移動。當再加入 EDTA 後，最大吸收峰波長

λmax回到538nm，恢復成甜菜紅素，未來可作為重金屬離子指示劑。 

壹、研究動機 

    紅龍果原產於南美洲，近年來引進台灣種植，而在台灣風土適

應佳，病蟲害少且農藥用量低，已經成

為一年四季常見的水果，而其果肉色澤

鮮紅多汁，相當吸引我們的注意。翻閱

文獻，紅龍果肉呈現紫紅色是因為富含 

甜菜紅素，可作為天然色素、及抗氧化

的功能。色澤鮮豔的甜菜紅素 Betalain

是一個 1,7-重氮七聚物結構的衍生物，

由甜菜醛胺酸 betalamic acid 與環多巴

cyclo-Dopa 結合而成，其紫紅色歸因於

共軛不飽和雙鍵的存在引起共振結構，

可見光之最大吸收峰波長 λmax 約在

535-538nm。二年級下學期自然與生活

科技第三章酸鹼鹽的課程裡，說明葡

萄、紅鳳菜與高麗菜這些植物皆含有花

青素，可做為酸鹼指示劑，和花青素類似，甜菜紅素在不同 pH 值

環境表現不同顏色，也代表吸收不同可見光的波長。我們想藉由製

作簡易光譜儀，分析甜菜紅素的吸收光譜波長，了解其特性。 

貳、研究目的 

一、製作簡易光譜儀 

二、紅龍果肉色素之甜菜紅素取得 

三、以簡易光譜儀測量分析甜菜紅素稀釋不同濃度、不同有機溶劑、

不同 pH 值、芬頓試劑、不同的重金屬離子的吸收光譜 

參、研究設備及器材 

一、研究設備 

水果刀、紗布手帕、離心機、離心管、電子天平、紙箱、微量吸管

（micropipette）、微量吸管吸頭、燒杯、塑膠比色管、科學 maker

分光器、手機、腳架、手機夾、省電燈泡、鎢絲燈泡 3W、檯燈燈

座、樂高積木、燈泡座、插座延長線、影像分析軟體 Image J、數

據分析軟體 Microsoft Office Excel 2016 

二、研究藥品 

紅龍果、硫酸銅、氫氧化鈉、濃鹽酸、硫酸銨亞鐵、甲醇、藥用酒

精、丙酮、氯化亞鈷、硝酸鉛、異丙醇、廣用試紙、雙氧水 

肆、研究過程或方法 

一、簡易光譜儀的製作 

 

圖三 簡易光譜儀示意圖 

    光譜儀是最常用於物質的結構鑑定分析的儀器，但是國中的

實驗室，並沒有此項儀器，於是參考多篇文獻並改良製作簡易光

譜儀。光譜儀是由光源、樣品槽（樣品比色管）、分光器、光譜

接收器（手機光譜儀）所組成，當光源發射的入射光 Io 通過樣品

容器時被容器中的物質吸收部份的光，透射光 I 經分光器分光

後，到達光譜接收器再由電腦分析處理（Image J、Excel）轉化

成光譜圖，經分析比對光譜資料可以了解物質的結構和成分，如

圖三。又依據比爾—朗博定律（Beer–Lambert law） 

    一束單色光照射於一吸收介質表面，在通過一定厚度的介質

後，由於介質吸收了一部分光能，透射光的強度就要減弱。吸收

介質的濃度愈大，介質的厚度愈大，則光強度的減弱愈顯著，其

關係為： 

A = log10 
𝐼0

𝐼𝑡
 = log10 

1

𝑇
 = ε•b•c   （式一） 

 A：吸光度、Io：入射光的強度、It：透射光的強度、T：透射

比、ε：莫耳吸光係數、b：吸收介質的厚度、 c：吸光物質的濃

度 mol/L 

光譜儀製作過程 

（一）暗箱的製作 

（二）光源 

1. 本實驗使用 3W 鎢絲燈泡作為光

源，是連續光譜（波長約

380nm~680nm）。使用省電螺旋燈泡

作為校正光源，是不連續光譜，在

波長 546nm 和波長 611nm 有激發光，作為光譜校準使用。  

2. 將燈座以樂高積木與黑色膠帶固定，裝上 3W 鎢絲燈泡，連接

單一插座延長線，使用電源 110 伏特。 

（三）樣品槽 

樣品槽是以連接（二）光源繼續以樂高積木堆疊成空心長方體結構，

可以讓放入方形比色管，並在放比色管的一面，放上黑色紙板，紙

板開一長 3 公分，寬 0.3 公分隙縫。 

  

圖五 光源樣品槽 圖六光譜儀 

 

（四）分光器與光譜接收器：使用科學 Maker 的分光器，連接

手機，就為手機光譜儀，由於該裝置就具有分光器與光譜接收的

功能，以手機的照相功能拍攝記錄分光圖。將手機光譜儀的狹縫

貼近黑色紙板的隙縫，並以腳架固定，就為光譜儀 

（五）光譜資料轉換 

1. 下載影像分析軟體 Image J 

2. 將手機光譜儀所拍攝的分光圖照片，以 Image J 及 Excel 2016 處

理，就可以得到吸收光譜圖 

（六）校準光譜儀 

（七）簡易光譜儀 

 

  圖七 省電燈泡分光圖    圖八 純水分光圖       圖九 甜菜紅素分光圖 

1. 手機光譜儀先拍攝省電燈泡分光圖，如圖七 

2. 以鎢絲燈為光源，取蒸餾水，放入方形比色管，置於樣品槽中，

拍攝只有水的分光圖，如圖八。 

3. 另取一方形比色管，接著放入 2.5% 甜菜紅素，置於樣品槽中，，

拍攝甜菜紅素分光圖，如圖九。 

4. 在 Image J 的工具列中，選 Stacks → Images to Stack，即可將三

張圖（圖七、八、九）疊在一起，以 Image J 軟體，轉換純水像素

強度，就為 Io，轉換甜菜紅素水溶液像素強度，就為 It，將兩者的

數據，輸入運算公式 log10 

𝐼0

𝐼𝑡
所得的值，就是吸光度 A。Excel 2016

數據繪出甜菜紅素的吸收光譜圖。所以在光譜圖，中縱軸的吸光度

A 值=0.89，甜菜紅素的 ε=60000L/mol，樣品槽比色管的厚度 1cm，

［甜菜紅素］=1.48*10-5M。 

 
圖一 紅龍果與果肉 

 
圖二 甜菜紅素結構 

 

圖四 暗箱與狹縫 



 

              圖十 甜菜紅素光譜圖               圖十一 文獻報導甜菜紅素光譜 

二、紅龍果肉色素之甜菜紅素的製備 

1. 市場購買紅龍果，以水果刀剝去外皮，切成數塊，放入冰箱冷凍 48 小時。 

2. 當已成冰凍狀態 48 小時後，拿出退冰，回到室溫。 

3. 回到室溫後，紅龍果肉的細胞壁破裂，紫紅色果汁就會大量滲出。以紗布

方巾當作濾網，濾出果肉、種子與黏稠果漿。 

4.濾液分別放入離心機，以轉速 6000rpm，離心 15 分鐘後，待離心機停止，以

滴管取離心管中紫紅色液體上層液 6mL，此紫紅色液體就為 100% 甜菜紅素。 

伍、研究結果與討論 

一、紅龍果肉色素之甜菜紅素取得 

甜菜紅素是一種水溶性的天然色素，以冷凍法來取得，再以離心機離心，得

幾乎無法透光紫紅色液體，以滴管吸取上層液體，該液體的濃度為 100%，加

水稀釋成 2.5%（DF=40），簡易光譜儀測量，光譜圖中吸光度 A 值=0.89，代入

式二中 

甜菜紅素的含量（mg/L）= 
   A× DF× MW× 1000   

𝜀×L
    （式二） 

A：吸光度，DF：稀釋倍數，MW= 甜菜紅素分子量= 550 g/mol， 

           ε= 60000 L/mol cm in H2O，L = 比色管寬度 = 1 cm 

即甜菜紅素含量 326 mg/L。而文獻中的方法，甜菜紅素的含量 120±25 mg/L，

紅龍果肉以乙醇萃取甜菜紅素，純度雖然較高，過程中甜菜紅素會發生降解，

降低產率。 

二、以簡易光譜儀分析甜菜紅素在不同環境的吸收光譜圖 

   

                圖十二                                      圖十三  

    甜菜紅素的吸光值很高，ε = 60000 L/mol，

設定離心後的甜菜紅素的濃度為 100%，加入

去離子水，稀釋成 2.5%時，λmax= 538nm，甜

菜紅素濃度高時，最大吸收峰波長會往短波長

移動。 

    稀釋濃度與吸光度作校正曲線（圖十

四），得 y=0.1091*x+3E-16 線性函數，曲線

上的 R2=1，表示為可用的曲線，未來只要有

吸光度，即可得知甜菜紅素濃度。                        圖十四 

    甜菜紅素放入水：溶劑=1：1，外觀呈色皆為紫紅色

溶液，圖十三光譜圖差異就非常明顯，甲醇、乙醇、異

丙醇與丙酮在 538nm 的吸光度降低、波形也相似，說明

甜菜紅素在這四種有機溶劑中不安定會分解。尤其在乙

醇溶液中，部分甜菜紅素已經降解成其他物質，

λmax=460nm~480nm 則為一起存在於紅龍果肉的物質，為

甜菜黃素 betaxanthin（圖十五），含量通常約為甜菜紅素

的 1/10。                                                 圖十五 

    甜菜紅素放入配製不同濃度的 HCl 溶液，以廣用試紙測其 pH 值，溶液

皆呈酸性，並且外觀亦呈紫紅色如圖十六。在圖十八光譜圖中，不同的 pH 值，

波形與甜菜紅素相似，隨 pH 值降低，在 538nm 吸光度也降低，波峰有 2-3nm

左移，太酸環境會使甜菜紅素發生異構化或去糖苷但不會裂解。以 538nm 的

吸光度來代表甜菜紅素的穩定度，吸光度越高者，穩定度越高，甜菜紅素

pH=5.8 > pH=6 > pH=7 > pH=3 > pH=2 >pH=1。 

    甜菜紅素放入不同濃度的 NaOH 溶液，以廣用試紙測 pH 值=8~13，溶液

皆呈鹼性，外觀顏色隨 pH 值增加，依序為粉紅、紫色、黃色、淡黃色、淺綠

色如圖十七，差異相當大，圖十九光譜圖的變化更為明顯，隨著 pH 值增加，

538nm 的吸光度降低。pH>10 時，在 430nm 處有吸收峰，為甜菜醛胺酸，更

鹼的環境時，吸光度增加，但 538nm 吸收峰消失，甜菜紅素已經降解，外觀

也沒有紫紅色。這是甜菜紅素於 C-11 被 OH-親核性攻擊（式三），亞胺腱斷

裂，降解成黃色甜

菜 醛 胺 酸

Betalamic acid 

λmax=420-450nm）

與環多巴 cyclo-

dopa（無色），造

成共振不連續而

失去顏色。說明甜

菜紅素於 pH>10 的鹼性環境中不穩定，色素分子會分解，紫紅色消失。 

 

              圖十八                              圖十九 

（式三） 

 

 

        圖二十 

    過氧化氫 H2O2 溶液中，加入少

量亞鐵離子 Fe2+，即產生大量的氫氧

自由基 HO．，是一種強氧化劑，可

將有機物分解，此為芬頓試劑，加入

紫紅色甜菜紅素，紫紅色立即褪色為黃褐色，如圖二十。   圖二十一 

    圖二十一光譜圖中，甜菜紅素溶液只加入過氧化氫 H2O2 或亞鐵離子 Fe2+

時，皆有 λmax=538nm，表示此兩物質，不影響甜菜紅素的結構，一加入過氧

化氫 H2O2 時，瞬間為芬頓試劑，外觀紫紅色立即消失，而在圖二十一

λmax=538nm 不見，但在波長 420nm 處有很大的吸收，為甜菜醛胺酸，甜菜紅

素結構被芬頓試劑的氫氧自由基所分解，為氧化還原反應，甜菜紅素為抗氧

化劑（還原劑），具抗氧化功能。利用芬頓試劑產生的自由基當作是人們身體

內的自由基，攝取紅龍果，紅龍果內的甜菜紅素就是作為清除體內的自由基

的抗氧化劑。 

    在紫紅色甜菜紅素水溶液中，分別加入 Cu2+、Fe2+、Pb2+、Co2+不同種類

的金屬離子，外觀呈色會改變如圖二十二。加入淡藍色的銅離子，為 Cu2+-甜

菜紅素溶液，顏色呈紫色；加入淺黃色的亞鐵離子，為 Fe2+-甜菜紅素溶液，

顏色呈紫紅色；加

入無色的鉛離子，

為 Pb2+-甜菜紅素

溶液，顏色呈淡粉

紅色；加入紅色的

亞 鈷 離 子 ， 為

Co2+-甜菜紅素溶

液，顏色呈橘紅色。 

 

               圖二十四                                圖二十五 

    圖二十四藍色硫酸銅水溶液其 λmax=660nm；顏色呈紫色 Cu2+-甜菜紅素 

 

圖十六 

 

圖十七 

  

圖二十二 圖二十三 



  
          圖二十六                             圖二十七 

溶液其 λmax=500nm，兩甜菜紅素溶液的 Δλmax=38nm，吸收峰波長

往短波長移動為藍位移，加入更多的硫酸銅時，在 500nm 的吸光

度會下降，表示 Cu2+-甜菜紅素溶液不穩定。 

    圖二十五淡黃色硫酸亞鐵水溶液 λmax= 407nm、λmax= 690nm）；

顏色呈紫紅色 Fe2+-甜菜紅素溶液 λmax= 540nm，兩甜菜紅素溶液的

Δλmax=2nm，吸收峰波長往短波長移動為紅位移，加入更多的硫酸

亞鐵，在 λmax=540nm 吸光度稍微下降。 

    圖二十六顏色呈淡粉紅色的 Pb2+-甜菜紅素溶液 λmax=495nm，

與甜菜紅素溶液的 Δλmax= 43nm，吸收峰波長往短波長移動為藍位

移，加入更多的硝酸鉛，在 λmax=495nm 吸光度上升。 

    圖二十七紅色氯化亞鈷水溶液 λmax=507nm； 顏色呈橘紅色的

Co2+-甜菜紅素溶液長 λmax=480nm，兩甜菜紅素溶液的 Δλmax=58nm，

吸收峰波長往短波長移動為藍位移，在 λmax=480nm 吸光度上升。 

    除了加入 Fe2+外，甜菜紅素加入重金屬離子 Cu2+、Pb2+、Co2+，

最大吸收峰波長接往短波長移動，這是因為在甜菜紅素分子結構

裡，有胺基與羧基，可提供電子對與金屬離子配位，這種具有配位

金屬離子的特質，稱之為螯合，就像螃蟹的螯夾住金屬離子，形成M2+-

甜菜紅素錯合物（如圖二十八），使得原先甜菜紅素上共軛不飽和

雙鍵的共振結構電子密度改變，共振穩定度也會改變，最大吸收峰

波長就會移動，往短波長移動，稱為藍位移。 

  
圖二十八 M2+-甜菜紅素結構圖 圖二十九 EDTA 結構圖 

    EDTA 是一種有機化合物，可以配位錳（II）、銅（II）、鐵（III）

及鈷（II）等金屬離子組成錯合物，它有 4 個酸和 2 個胺的構成六

牙基的配位基，配位能力比甜菜紅素強（如圖二十九）。 

    為證明重金屬離子 Cu2+、Fe2+、Pb2+、Co2+確實與甜菜紅素進行

配位成錯合物。在甜菜紅素中加入過量的重金屬離子，形成 M2+-

甜菜紅素錯合物，接著逐滴加入 EDTA，錯合物上的 M2+就與 EDTA

形成 M2+-EDTA 錯合物，重金屬離子不再與甜菜紅素配位，就恢復

成甜菜紅素，圖二十三外觀呈色有部分恢復呈紫紅色，但因溶液中

尚有 M2+-EDTA 存在，外觀呈色是甜菜紅素與 M2+-EDTA 錯合物兩種

溶液混合顏色。 

  

            圖三十                             圖三十一 

  
            圖三十二                           圖三十三 

圖三十 Cu2+-甜菜紅素錯合物溶液 λmax=500nm，在逐漸加入

EDTA 時，λmax 往 538nm 移動，此為甜菜紅素的最大吸收峰波長，

表示甜菜紅素已無與 Cu2+螯合，圖三十右端另一 λmax=660nm，是

為 Cu2+-EDTA 錯合物，其外觀呈深藍色，與紫紅色甜菜紅素同時在

比色管中，才使溶液呈紫色。 

    圖三十一 Fe2+-甜菜紅素錯合物溶液 λmax=540nm，逐漸加入

EDTA，最大吸收峰波長往 538nm 移動，此為甜菜紅素的最大吸收

峰波長，λmax差異很小，溶液外觀呈色皆為紫紅色，不易分辨顏色

差別。 

圖三十二 Pb2+-甜菜紅素錯合物溶液其最大吸收峰波長

λmax=495nm，在逐漸加入的 EDTA 時，λmax往 538nm 移動，此為甜

菜紅素的最大吸收峰波長，此時溶液會轉變回紫紅色，表示甜菜紅

素已無與 Pb2+螯合。 

圖三十三 Co2+-甜菜紅素錯合物溶液 λmax=480nm，逐漸加入

EDTA，最大吸收峰波長移到在 500~550nm，此時溶液外觀為紅紫

色，這是因為溶液中有 Co2+-EDTA錯合物 λmax=504nm，外觀呈紅色，

與紫紅色甜菜紅素同時在比色管中，才使溶液呈紅紫色。 

  

           圖三十四                             圖三十五 

  

           圖三十六                             圖三十七 

   將各重金屬離子、甜菜紅素、M2+-甜菜紅素、M2+-甜菜紅素-EDTA、

M2+-EDTA 的吸收光譜圖，疊圖就比較出最大吸收峰波長的移動差

異如圖三十四、三十五、三十六、三十七。當紫紅色的甜菜紅素加

入重金屬離子，其外觀呈色會隨重金屬種類不同，我們認為，甜菜

紅素可做為重金屬離子檢測的指示劑。 

陸、結論 

1. 以鎢絲燈泡、樂高積木、紙箱、科學 maker 分光器與手機，製

作簡易光譜儀，手機拍攝的分光照片。利用影像分析軟體 Image J，

數值再以 Excel 2016 運算，所畫的曲線圖，橫坐標為波長，縱座標

為光強度之光譜圖。 

2. 吸收光譜圖則是利用比爾—朗博定律，在 Excel 2016 運算後就

得樣品的吸光度 A。甜菜紅素以簡易光譜儀測量，畫出的吸收光譜

圖，其最大吸收峰波長 λmax=538nm，與文獻一致。 

3. 甜菜紅素用冷凍法、離心、分離後，濃度為文獻報告的 2 倍。 

4. 甜菜紅素消光係數數值很大，測量吸收光譜時，將取得的甜菜

紅素溶液，稀釋至 2.5%以下，才能使吸光度 A 值的範圍在 0.8 

≤A≤1.0，λmax=538nm，當甜菜紅素濃度高時，最大吸收峰波長會

往短波長移動。 

5. 甜菜紅素在不同酸鹼環境中的穩定度，λmax=538nm 吸光度 A 值

大小作判斷，吸光度越高者，穩定度越高，甜菜紅素在 pH 值 5~9

最穩定、在 pH 值>10 環境不穩定，色素分子會分解，紫紅色消失。 

6. 甜菜紅素在醇類不穩定尤其是在乙醇溶液，故不宜以乙醇從紅

龍果肉萃取甜菜紅素。 

7. 甜菜紅素與加入芬頓試劑時，紫紅色立刻褪去，表示具有抗氧

化能力，可作為抗氧化劑。 

8. 甜菜紅素可以與重金屬 Cu2+、Fe2+、Pb2+、Co2+螯合成錯合物，

使穩定度改變，造成外觀呈色改變，在吸收光譜圖中 λmax 會往短

波長移動，當 M2+-甜菜紅素錯合物加入 EDTA 時，λmax會移回 538nm，

證明金屬離確實與甜菜紅素螯合，說明未來甜菜紅素可作為重金

屬離子的指示劑。 
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